Установка Cloud Hosted Router на VPS

Рассмотрим процесс установки Mikrotik CHR на хостинг с VPS (на примере хостинг-провайдера Fornex). Для личных целей достаточно самой простой виртуальной машины с 1 vCPU и 1 GB vRAM.

Далее выбираем образ ОС, панель управления VPS и локацию. Так как Mikrotik Cloud Hosted Router не входит в стандартный набор образов большинства провайдеров, возьмем любую linux-систему (в примере — Ubuntu) и после получения доступа к виртуалке перережем её.

После того, как виртуалка готова, подключаемся по ней по ssh и устанавливаем дополнительные пакеты.

$ ssh root@1.2.3.4
Password:

$ apt-get -y install unzip net-tools

Выясняем сетевые настройки, чтобы после установки CHR не пришлось писать провайдеру запросы. В примере IP машины — 1.2.3.4, маска — 255.255.255.0 (/24), шлюз — 1.2.3.1.

$ ifconfig | grep inet | grep netmask
        inet 1.2.3.4  netmask 255.255.255.0  broadcast 1.2.3.255
        inet 127.0.0.1  netmask 255.0.0.0
$ route | grep default
default         1.2.3.1       0.0.0.0         UG    0      0        0 eth0

Далее переходим на сайт Mikrotik, копируем ссылку на образ Cloud Hosted Router в формате Raw disk image, скачиваем его на виртуальную машину и распаковываем:

$ wget https://download.mikrotik.com/routeros/7.1/chr-7.1.img.zip
$ unzip chr-7.1.img.zip 
Archive:  chr-7.1.img.zip
  inflating: chr-7.1.img

Выясняем имя раздела в системе (в примере — /dev/vda):

$ fdisk -l | grep Disk | grep dev
Disk /dev/vda: 10 GiB, 10737418240 bytes, 20971520 sectors

Записываем образ CHR на диск и перезапустим виртуалку:

$ dd if=chr-7.1.img of=/dev/vda
262144+0 records in
262144+0 records out
134217728 bytes (134 MB, 128 MiB) copied, 8.67628 s, 15.5 MB/s
$ echo 1 > /proc/sys/kernel/sysrq
$ echo b > /proc/sysrq-trigger

После этого ВМ перезапустится с новой ОС, в которой отсутствуют сетевые настройки, соответственно поключиться можно только через консоль ВМ в личном кабинете (Заказы<имя_ВМ>Консоль).

Авторизуемся с дефолтными кредами — admin без пароля. Сразу будет предложено создать новый пароль.

Mikrotik 7.1 (testing)
Mikrotik Login: admin
Password:

Change your password

new password> **********
repeat new password> **********

Password changed
[admin@Mikrotik] >

Применим сетевые настройки и назначим dns:

[admin@Mikrotik] > /ip address add interface=ether1 address=1.2.3.4 netmask=255.255.255.0
[admin@Mikrotik] > /ip route add gateway=1.2.3.1 dst-address=0.0.0.0/0 distance=1
[admin@Mikrotik] > /ip dns set servers=103.196.38.38,103.196.38.39

Указанные DNS (103.196.38.38,103.196.38.39) поддерживают в т.ч. handshake-домены.

Теперь можно подключиться через Winbox или веб-интерфейс.

Дефолтно на CHR применяется бесплатная лицензия (Free), которая ограничивает пропускную способность скоростью 1 мбит/с. Платные варианты лицензий — P1 (1 Гбит/с), P10 (10 Гбит/с) и P-unlimited (без ограничений). Статус лицензии можно увидеть в System — License.

Для активации платной лицензии кликните на Renew License и введите свои креды от личного кабинета на сайте Mikrotik. После этого в личном кабинете в разделе All CHR Keys появится System ID установленного экземпляра CHR, там же можно назначить ему имеющуюся лицензию.

Готово, ваш CHR установлен и готов к работе.

Оставьте ответ

Ваш адрес email не будет опубликован.